New application server role on farm not getting traffic from nginx instance (www load balancing)

Arie Fishler's Avatar

Arie Fishler

22 Jul, 2014 12:19 PM

My Farm 3782 is configured with one www instance (nginx) and two different roles of application servers.

I created a new role of application server to switch to new generation servers.
I wanted to switch my traffic to the new role and suddenly recalled that the load balancer nginx instance was supposed to automatically direct all traffic to any application server role.
However - my new role platform-tomcat7-ubuntu1404 is not getting any traffic.
How do I do it these days?

  1. Support Staff 1 Posted by Marat Komarov on 22 Jul, 2014 12:47 PM

    Marat Komarov's Avatar

    This old rule works only for app servers for backward compatibility, tomcat role has it's own behavior tomcat. The new way to define proxies is "Proxy settings" tab in Nginx role settings in Farm designer

  2. Support Staff 2 Posted by Marat Komarov on 22 Jul, 2014 12:52 PM

    Marat Komarov's Avatar

    To apply new settings you should restart scalarizr on nginx. Also take in mind that when you define proxies in UI, old default rules not applied.

  3. 3 Posted by Arie Fishler on 23 Jul, 2014 01:27 PM

    Arie Fishler's Avatar

    ok...thanks. BTW how do I restart scalarizr?

  4. 4 Posted by Dmitry Korsakov on 23 Jul, 2014 01:32 PM

    Dmitry Korsakov's Avatar

    You can restart scalarizr from "Server status" page.

  5. Marat Komarov closed this discussion on 20 Jan, 2015 10:27 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac