Problem setting 0.0.0.0/0 on security groups for AWS classic via scalr?

Eric Hellman's Avatar

Eric Hellman

31 Aug, 2018 05:59 PM

So, I think AWS may have changed their API for managing security groups, very likely to allow handling of IPv4 and IPv6 quickly, by adding an option to choose "Any IP" as a separate flag instead of just accepting 0.0.0.0/0

I tried earlier to add 0.0.0.0/0 as the range on a security group earlier today in scalr, and was told an error was the result.
I did the same via the AWS web UI and saw the new structure, and received an error when trying the old way in AWS, I then selected the pulldown option for Any IP and it worked. Maybe the version of the AWS API that hosted scalr is using for managing security groups in classic has suddenly become disabled by AWS.

  1. Support Staff 1 Posted by Vitaliy Demidov on 03 Sep, 2018 05:22 PM

    Vitaliy Demidov's Avatar

    Hi Eric,
    Recently we issued a fix related to the saving AWS Security Groups. Can you confirm whether the problem has gone, and if not please attach a screen shot with the error you got in Scalr.

    Regards,
    Vitaliy Demidov

  2. Support Staff 2 Posted by Vitaliy Demidov on 05 Sep, 2018 11:37 AM

    Vitaliy Demidov's Avatar

    Scalr uses latest version of the EC2 API which won't be suddenly disabled by AWS.
    For the IPv6 handling there are an Ipv6Ranges field inside IpPersmission data type that does a trick https://docs.aws.amazon.com/AWSEC2/latest/APIReference/API_IpPermis...

    At this time, I'm marking this case as Resolved. However, if you're still experiencing issues, I want to hear from you! Please re-open this case for continued support.

  3. Vitaliy Demidov closed this discussion on 05 Sep, 2018 11:37 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac