RepositoryError: Cant get repo metadata HTTP error code: 404

kenorb's Avatar

kenorb

10 Nov, 2017 02:04 PM

My goal is to upgrade Scalr agent v3.6.7 to the latest stable 5.x on the existing image. Since an auto-update agent isn't available for the older version, I had to launch the instance and install Scalr agent manually (scalarizr_5.11.6.msi) as per suggestion from here. I've uninstalled the old one, and installed the new one into new location (/opt instead of /Program Files), however now when running the server instance (62237c55-d611-4f57-bb06-7fb9ba16c148), it's reported that Scalarizr is Not available and I've got the following error:

Error: <span style="color: #f9b09d;">Scalarizr status is not available: RepositoryError: Cant get repo metadata HTTP error code: 404 (-32603):  ({"id": 1510322470.4599, "error": {"message": "RepositoryError: Cant get repo metadata HTTP error code: 404", "code": -32603, "data": null}})</span><br/>

How should I approach this issue in order to upgrade my Scalarizr version as per suggestion from here?

Why does it says that the repo metadata does not exist? Is there any config to point to the right repo?

  1. Support Staff 1 Posted by Marat Komarov on 10 Nov, 2017 06:00 PM

    Marat Komarov's Avatar

    Please attach all log files from c:\opt\scalarizr\var\log

    Regards,
    Marat

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac