scalarizr - undefined method `property' for Chef::Resource::OhaiHint:Class

qibin.tan's Avatar


13 Jun, 2017 04:24 PM

Hi, when I'm using Scalr to bootstrap with chef and choose the trigger event as "BeforeHostUp" in the Orchestration part, the error as in the attachment shows. I used Scalr to do this deployment for half a year, it runs well previous. This issue just happened recently. Could you give me some suggestion about "undefined method `property' for Chef::Resource::OhaiHint:Class" error.
Note: I tried both chef-client version - 12.1.2 and 13.1.x. It shows the same error.


  1. Support Staff 1 Posted by Marat Komarov on 13 Jun, 2017 05:15 PM

    Marat Komarov's Avatar

    This error is from cookbook compiler. Please make sure that cookbook works with chef-client version installed on this server.


  2. Marat Komarov closed this discussion on 18 Dec, 2017 06:46 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

19 Mar, 2018 07:00 PM
14 Mar, 2018 08:11 PM
15 Feb, 2018 06:29 AM
13 Feb, 2018 12:10 PM
10 Jan, 2018 08:14 PM