load balancer not updating app members

dan's Avatar

dan

13 Jun, 2016 05:47 PM

farm 22046, role 100302, server id ca733a57-07a0-4fae-9bef-30c4eade6680

The app members of the load balancer group are not getting updated as new servers are started or terminated in the app role. The following message appears repeatedly in /var/log/scalarizr.log

2016-06-13 17:34:04,486+00:00 - ERROR - scalarizr.handlers - 'NginxAPI' object has no attribute 'app_servers_inc'
2016-06-13 17:34:04,489+00:00 - INFO - scalarizr.handlers - Executing 1 HostDown script(s)

This issue happened previously on a different instance of this role, so I terminated it and started a new one on Friday. It appeared to be working correctly. However, now it is not working anymore.

  1. Support Staff 1 Posted by Marat Komarov on 13 Jun, 2016 07:32 PM

    Marat Komarov's Avatar

    Fixed error in Scalr agent.

    FYI: there is a duplicate upstream "backend" somewhere in configuration (it's reserved for Scalr automation). Therefore nginx reload doesn't work and changes in app-services.include currently not applied.

    Regards,
    Marat

  2. marc closed this discussion on 22 Jul, 2016 08:43 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

02 Jul, 2019 07:54 PM
07 Jun, 2019 07:12 PM
02 May, 2019 04:04 PM
28 Mar, 2019 05:24 PM
22 Feb, 2019 08:11 PM