Scalrizr for windows 3.3.8-1.x86_64 Windows 2012R2 on EC2

Richard Bevan's Avatar

Richard Bevan

12 Feb, 2015 04:11 PM

2015-02-12 16:06:42,769+00:00 - DEBUG - scalarizr.app - Initialize platform
2015-02-12 16:06:42,838+00:00 - DEBUG - scalarizr.app - Checking EC2Config completion
2015-02-12 16:06:42,838+00:00 - DEBUG - scalarizr.app - Creating WMI object EC2_ConfigService
2015-02-12 16:06:42,880+00:00 - ERROR - scalarizr.app - (-2147217392, 'OLE error 0x80041010', None, None)
Traceback (most recent call last):
  File "C:\Program Files\Scalarizr\src\scalarizr\app.py", line 556, in main
    svs.start()
  File "C:\Program Files\Scalarizr\src\scalarizr\app.py", line 1210, in start
    super(WindowsService, self).start()
  File "C:\Program Files\Scalarizr\src\scalarizr\app.py", line 655, in start
    self._wait_windows_ready()
  File "C:\Program Files\Scalarizr\src\scalarizr\app.py", line 810, in _wait_windows_ready
    return self._wait_ec2config_ready()
  File "C:\Program Files\Scalarizr\src\scalarizr\app.py", line 793, in _wait_ec2config_ready
    wmi_ec2_config()
  File "C:\Program Files\Scalarizr\src\scalarizr\app.py", line 783, in wmi_ec2_config
    return iter(wmi.InstancesOf('EC2_ConfigService')).next()
  File "C:\Program Files\Scalarizr\Python27\Lib\site-packages\win32com\client\util.py", line 84, in next
    return _get_good_object_(self._iter_.next(), resultCLSID = self.resultCLSID)
com_error: (-2147217392, 'OLE error 0x80041010', None, None)

  1. Support Staff 1 Posted by Marat Komarov on 12 Feb, 2015 05:21 PM

    Marat Komarov's Avatar

    Do you have EC2Config installed on this server? Could you also attach Windows Event Log and scalarizr_update.log?

  2. 2 Posted by Richard Bevan on 12 Feb, 2015 05:24 PM

    Richard Bevan's Avatar

    Hi Yes running version 2.3.313.0 of the EC2 Config Service

  3. 3 Posted by Richard Bevan on 12 Feb, 2015 05:31 PM

    Richard Bevan's Avatar

    Here are the logs Thanks

  4. 4 Posted by Jason Dobyns on 15 Feb, 2015 10:05 PM

    Jason Dobyns's Avatar

    We are having this exact same Issue
    it happens with 3.3.9 on Windows 2012 r2

    Also we had downgraded to scalarizr 3.2.2 which worked, but then the servers have auto updated back to 3.3.9.

    We are evaluating Scalr to replace rightscale and the client that makes the entire thing work seems like it should get a bit more QA before forcing clients to update.

  5. 5 Posted by Jason Dobyns on 15 Feb, 2015 10:10 PM

    Jason Dobyns's Avatar

    How can we force a specifc version of scalarizr to be installed ?

    I can manually downgrade it, but its just going to upgrade itself again.

  6. 6 Posted by William Kray on 15 Feb, 2015 10:33 PM

    William Kray's Avatar

    I am also seeing this same issue. Auto updates should be configurable to only upgrade to the latest STABLE version. Downgrading as suggested by Jason Dobyns worked, but we also can't keep it from automatically upgrading.

  7. Support Staff 7 Posted by Igor Savchenko on 16 Feb, 2015 01:54 AM

    Igor Savchenko's Avatar

    You can configure which branch to use: Latest or Stable on Farm extended information page (for entire farm) or on Advanced tab in FarmDesigner for specific role.

    We're looking into this issue in 3.3.X branch.

    Regards,
    Igor

  8. 8 Posted by Richard Bevan on 16 Feb, 2015 09:42 AM

    Richard Bevan's Avatar

    I can confirm 3.1.33 works but so far 3.3.9, 3.3.8 and 3.3.7 doesn't work at all.

    Thanks

    Richard

  9. Support Staff 9 Posted by Marat Komarov on 16 Feb, 2015 11:12 AM

    Marat Komarov's Avatar

    Richard, and others.

    Scalarizr 3.3.10 should work fine. Please confirm that it resolves your issues.

    Regards,
    Marat

  10. 10 Posted by Richard Bevan on 16 Feb, 2015 12:31 PM

    Richard Bevan's Avatar

    Thanks when will 3.3.10 be uploaded to http://repo.scalr.net/win/latest/x86_64/

    Thanks

  11. Support Staff 11 Posted by Marat Komarov on 16 Feb, 2015 12:38 PM

    Marat Komarov's Avatar

    It's already there.

    Regards,
    Marat

  12. 12 Posted by Richard Bevan on 16 Feb, 2015 12:48 PM

    Richard Bevan's Avatar

    Thanks

  13. 13 Posted by Jason Dobyns on 16 Feb, 2015 06:38 PM

    Jason Dobyns's Avatar

    I can also confirm that 3.3.10 works.

    However, my farms were already set to stable for their repo's. Yet I have servers that updated to 3.3.10

  14. Marat Komarov closed this discussion on 25 Feb, 2015 09:36 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

02 Jul, 2019 07:54 PM
07 Jun, 2019 07:12 PM
02 May, 2019 04:04 PM
28 Mar, 2019 05:24 PM
22 Feb, 2019 08:11 PM